cPanel Email Outage
Incident Report for Webics
Resolved
This incident has been resolved.
Posted Feb 01, 2021 - 13:55 AEDT
Investigating
We have identified an issue with the servers for some old cPanel hosting accounts that is preventing incoming emails from being received and are awaiting a fix to be pushed out. Please note this does not affect customers on Google Workspace or customers with their emails hosted on our newest servers.
Posted Feb 01, 2021 - 10:26 AEDT
This incident affected: Shared Hosting Service.